Currently we are supporting android and iOS only. For iOS you need to be running IOS version 12.0 or later, and for android version 6.0(Marshmallow) or later. We are currently collecting a list of phones that the app is not working on.

You might also like

Oops, there are no posts.